Error 404 image not found / artifact not found

Nexus server v3.37.3 was triggering errors like " artifact exists in metadata but not from blob store" which we solved by running the task “Repository - remove unused manifest and images”
At first we run this task manually since was not frequent to happen. But now is so frequent to happen in our private docker images repository that had to schedule it to run hourly.

Now is triggering the error “- 404 Images not found” on the log viewer lately. Looking around found that the problem gets fixed after creating and running the task “Repair repository browse”. However, the problem starts to happen more frequently so we have to schedule this task daily but concerned that will require running hourly too.

I tried to look for the cause of this problem in order to prevent those problems but found no clue. Does any know why metadata gets in this kind of condition that had to clean and rebuilt?

Appreciate any information.

Hi Miguel,
We’re sorry you experience this. A number of bug fixes for Docker format were released in 3.38.0. Can you try upgrading to the latest version and see it helps, please?