# Nexus hosted docker registry with changed NEXUS\_CONTEXT: nexus/

**URL:** <https://community.sonatype.com/t/nexus-hosted-docker-registry-with-changed-nexus-context-nexus/3371>\
**Category:** Sonatype Nexus Repository\
**Tags:** help\
**Created:** [January 24, 2020, 1:27pm UTC](https://community.sonatype.com/t/nexus-hosted-docker-registry-with-changed-nexus-context-nexus/3371 "2020-01-24T13:27:32Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![oleksandr.shkovyra](https://avatars.discourse-cdn.com/v4/letter/o/71c47a/32.png) [@oleksandr.shkovyra](https://community.sonatype.com/u/oleksandr.shkovyra)\
**Post date:** [January 24, 2020, 1:27pm UTC](https://community.sonatype.com/t/nexus-hosted-docker-registry-with-changed-nexus-context-nexus/3371/1 "2020-01-24T13:27:32Z")

</div>

Hello everyone!

I have created nexus and now I am trying to configure the private docker registry.  
Nexus locates on the changed path, like https://ip\_addr/nexus/.  
I have created a docker repo and enabled HTTP on 8083 port.  
Docker Registry API Support Enable Docker V1 API: enabled too.

I’ve added ip-address to insecure-registries.  
When I try to connect:  
$ docker login ip\_addr:8083/nexus/repository/docker-private/

```
Username: admin
Password: 

Error response from daemon: Get https://Ip_addr:8083/v2/: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)

```

* * *

```
$ docker login https://ip_addr:8083/nexus/repository/docker-private/

Username: admin
Password: 

Error response from daemon: Get https://ip_addr:8083/v2/: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)

```

* * *

```
$ docker login https://ip_addr/nexus/repository/docker-private/

Username: admin
Password: 

Error response from daemon: login attempt to http://ip_addr/v2/ failed with status: 404 Not Found
$ docker login http://ip_add/nexus/repository/docker-private/

```

* * *

```
$ docker login http://ip_addr/nexus/repository/docker-private/

Username: admin
Password: 

Error response from daemon: login attempt to http://ip_addr/v2/ failed with status: 404 Not Found

```

Should I configure something additionally?

---

<div class="post-metadata">

**Author:** ![navinprasad0808](https://yyz1.discourse-cdn.com/flex047/user_avatar/community.sonatype.com/navinprasad0808/32/1143_2.png) [@navinprasad0808](https://community.sonatype.com/u/navinprasad0808)\
**Post date:** [April 28, 2020, 6:05am UTC](https://community.sonatype.com/t/nexus-hosted-docker-registry-with-changed-nexus-context-nexus/3371/2 "2020-04-28T06:05:45Z")

</div>

Is the issue solved? I’m also facing the same issue.

---

<div class="post-metadata">

**Author:** ![mpiggott](https://avatars.discourse-cdn.com/v4/letter/m/f0a364/32.png) [@mpiggott](https://community.sonatype.com/u/mpiggott)\
**Post date:** [April 28, 2020, 2:04pm UTC](https://community.sonatype.com/t/nexus-hosted-docker-registry-with-changed-nexus-context-nexus/3371/3 "2020-04-28T14:04:45Z")

</div>

See the warning in the docks - [SSL and Repository Connector Configuration](https://help.sonatype.com/repomanager3/formats/docker-registry/ssl-and-repository-connector-configuration)
