OSS 2.14 - Can't resolve a single package, all is OK - how to diagnose further?

Nexus Repository Manager OSS 2.14.13-01

See, below - have tried the ?describe feature and the package in question looks OK.

Could there be a hidden network problem that is really causing this issue, but with this single package in our repo? It makes no real sense :stuck_out_tongue_winking_eye:

Has anyone else encountered anything like this?
Have also tried the expire cache feature.

This package fails on our build system:
-bash-4.2$ curl -i http://repo.***.com/nexus/content/groups/npm/json-schema/-/json-schema-0.2.3.tgz
curl: (56) Recv failure: Connection reset by peer

But the minor version after (for example) does not:
curl -i http://repo.***.com/nexus/content/groups/npm/json-schema/-/json-schema-0.2.4.tgz
HTTP/1.1 200 OK
Server: nginx/1.10.1
Date: Fri, 07 Aug 2020 12:33:36 GMT
Content-Type: application/x-gzip
Content-Length: 8791
Connection: keep-alive
X-Frame-Options: SAMEORIGIN
X-Content-Type-Options: nosniff
Accept-Ranges: bytes
ETag: “{SHA1{66f1dd303e8672dac684b246cb17859c841f5bb5}}”
Last-Modified: Fri, 07 Aug 2020 12:33:36 GMT
Warning: Binary output can mess up your terminal. Use “–output -” to tell
Warning: curl to output it to your terminal anyway, or consider "–output
Warning: " to save to a file.

It seems unlikely that this would be Nexus particularly if nothing is in the logs.

You should check configuration of proxies, and reverse proxies, otherwise perhaps your anti-virus software.