# Unable to start nexus on Centos9 or RedHat 9 with SSL - access denied error to keystore.jks

**URL:** <https://community.sonatype.com/t/unable-to-start-nexus-on-centos9-or-redhat-9-with-ssl-access-denied-error-to-keystore-jks/10749>\
**Category:** Best Practices\
**Tags:** ssl, nexus-repository\
**Created:** [June 6, 2023, 2:13pm UTC](https://community.sonatype.com/t/unable-to-start-nexus-on-centos9-or-redhat-9-with-ssl-access-denied-error-to-keystore-jks/10749 "2023-06-06T14:13:41Z")\
**Posts on this page:** 1\
**Showing post:** 1

<div class="post-metadata">

**Author:** ![katya.pichugin](https://avatars.discourse-cdn.com/v4/letter/k/b9bd4f/32.png) [@katya.pichugin](https://community.sonatype.com/u/katya.pichugin)\
**Post date:** [June 6, 2023, 2:13pm UTC](https://community.sonatype.com/t/unable-to-start-nexus-on-centos9-or-redhat-9-with-ssl-access-denied-error-to-keystore-jks/10749/1 "2023-06-06T14:13:41Z")

</div>

Hello,

Trying to install and configure nexusVersion=“3.32.0” on centos 9 and redhat 9. And came accross the following error:  
Failed to start  
java.nio.file.AccessDeniedException: /opt/sonatype/nexus/etc/ssl/keystore.jks

The same installation works fine on centos 7.9.

Noticed that openssl versions are different:  
OpenSSL 1.0.2k-fips for centos 7.9  
and OpenSSL 3.0.7 for Centos 9.

Also used the certs and keystore, created on 7.9, on centos 9 (used the same host name for both servers) and nexus WORKED.

So is there anything I need to do for it to work on centos 9 and redhat9?  
Thank you. Any advice would be highly appreciated.

---

_[View the full topic](https://community.sonatype.com/t/unable-to-start-nexus-on-centos9-or-redhat-9-with-ssl-access-denied-error-to-keystore-jks/10749)._
