Unable to start nexus on Centos9 or RedHat 9 with SSL - access denied error to keystore.jks

Yes, the files are the same.

Solved the issue by changing ownership to the nexus directory to nexus user: chown -R 200:200 $nexusDirectory.
Works without it in earlier versions (3.22) on centos 7.9

Thank you for all the help!