Access denied messages running Nexus as admin

I am trying to upgrade from v2 to v3. I was able to install successfully the first time, but then I had to reset my admin password in the middle of upgrading from v2. I am trying to do a clean reinstall of v3 to start over. I keep having problems with the db folder. I get messages like this:

Caused by: D:\sonatype-work\nexus3\db\config\database.ocf (Access is denied)

The messages vary. I didn’t have this trouble installing it the first time. I have tried deleting both the program folder and the nexus3 folder of the working directory. What else can I try? I am running it in Windows from a command prompt with admin privileges.

I’m not clear when you’re getting those messages? Can you be more specific?
You delete the install and data directories and unzip them so they’re fresh then what do you do?

I was getting those messages in the log file the first time I started Nexus after unzipping the working folder. The exact message was different each time, but it always seemed to be in the DB folder.

I was able to get it working. I didn’t do anything different. I deleted the working folder and unzipped it. I started Nexus, and it was fine. The only thing I can think of is that something was blocking it, like the antivirus. Not sure why it worked the first time and then this last time.