Artifacts not released to Maven Central

Hi - I have been using Nexus for about three years to deploy my library to Maven Central. Yesterday, I tried to release a new version of the library. The build and upload to Nexus seemed to succeed, but the library is not showing up, and so I tried again today. This is the first time in about ten months that I have done this so it may be that something has changed? Here is what I did:

  1. In my local repo, I ran the maven command: mvn -Prelease -Dgpg.executable=gpg2 clean deploy
  2. When prompted, signed the artifacts with my passphrase
  3. Using the maven output, verified that the staging repository with id comgithubmartinpg2001-1057 is created
  4. Verified that the artifacts are uploaded
  5. Using the maven output, that the remote staging repositories are released.
  6. Waited for some time, and then check Maven Central, but do not see the new library version there.

Here is the relevant output from the maven output:

[INFO] * Remote staging into staging profile ID “796def159936e2”
[INFO] * Created staging repository with ID “comgithubmartinpg2001-1057”.
[INFO] * Staging repository at
[INFO] * Uploading locally staged artifacts to profile com.github.martinpg2001
Uploading to ossrh:
… some lines removed for readability …
Uploaded to ossrh: (659 B at 3.2 kB/s)
[INFO] * Upload of locally staged artifacts finished.
[INFO] * Closing staging repository with ID “comgithubmartinpg2001-1057”.

Waiting for operation to complete…

[INFO] Remote staged 1 repositories, finished with success.
[INFO] Remote staging repositories are being released…

Waiting for operation to complete…

[INFO] Remote staging repositories released.
[INFO] ------------------------------------------------------------------------
[INFO] ------------------------------------------------------------------------

Using the Nexus Repository Manager UI, I can see that the artifacts are uploaded, but if I search for the staging repository with id comgithubmartinpg2001-1057 then nothing is found.

Any help would be greatly appreciated, Martin

I checked Maven Central today, and now the artifacts are present there, so that’s good! Is it unusual for the release to take so long? Martin

Hi this isn’t the right place for these questions, this forum is for Nexus Repository as a product. If you have problems for central you should consult the central documentation.