AWS CodeArtifact support in InnerSource configuration

Currently the InnerSource repository configuration supports only NXRM3 repositories.
Do you plan also to add support for e.g. AWS CodeArtifact repositories?

On that note, the “TEST” button behaviour is really misleading and it’s not testing properly at all (rel. 135), e.g.

  • an invalid or non-NXRM3 (like AWS CodeArtifact) URL returns: 502 Bad Gateway
  • putting ANY valid url (that returns 200 without authorization) causes the TEST to show SUCCESS while it is clearly invalid (non-nexus-repository url)

There is also one bug:

  • configure a repository on organisation level, allow to inherit and disallow to override, hit Enable and save
  • the repository is correctly inherited by the child applications
  • now, go back to organisation, do not remove the added repository from the list but select the radio option to “disable” innersource configuration and hit save
  • go back to the child apps, they will show the previously configured repository as still configured - you need to go back, enable, delete the repository and only then disable for this to have an effect

Hey, @rantoniuk thanks for reaching out, related to the bug you mention we are aware, and it’s been fixed and will be available in the next IQ release.

For the “TEST” button we are trying to reproduce the issue but haven’t been able to, when you say ANY valid URL, do you have any examples we could test with? we’ve been trying with www.google.com and we get an error message, also just to confirm could you please provide some screenshots of the results you are getting?.

About supporting AWS CodeArtifact, right now we don’t have any plans but can you please add that to our ideas portals so we can keep track of it https://ideas.sonatype.com

Thanks

1 Like

Dear @aalzate,

Thanks for prompt response.

#1 For the TEST issue, indeed, www.google.com returns 502 Bad Gateway (again, wrong error, it should say: not NXRM3.
About the URL used for tests, see the screenshot that says “Test successful” on a URL that is … internal Jira, same if I change it to internal Confluence - I don’t know what is the test request sent but it’s too generic I guess :slight_smile:

#2 For ideas.sonatype.com, unfortunately after logging in with GitHub, I’m getting this:

We are sorry…
Your Sonatype account gives you access to the Sonatype Customer Platform.
Your username or password entry is incorrect. Please try again.

Note, that on my GH profile I have multiple e-mail addresses, so it should offer to pick the non-gmail one in case it requires it.

#3 I have one other bug:

On the SCM repository configuration screen, there is a “Test Configuration” button:

When I click that button, it gets gray, but there is no output of the test. We discovered, that the Administrator sees the output, so it seems that there is a problem with permissions - even though I am able to configure the repository and I see the Test Connection button, I don’t see the box with test results if I’m not the instance admin.

Disregard the warning, it’s just for screenshot purpose so that you know which screen I’m talking about.

Hope that helps.

And second reply to attach second screenshot, as it didn’t allow me to attach two screenshots in one reply :zipper_mouth_face:

Hi @rantoniuk!

Thank you for those updates and screenshots. Hoping I can answer a few of your questions here.

  1. I have confirmed a ticket has been created on our side regarding this - will keep you updated on progress there.

  2. For ideas.sonatype.com, try signing in with your my.sonatype.com credentials - that is how the Ideas portal is accessible (the same credentials used to logged into this Community forum!) But please let us know if you are still having trouble.

  3. Thanks for letting us know about this bug - as a licensed Sonatype customer, you are able to open a support ticket around this - https://support.sonatype.com/hc/en-us/requests/new - they will be best suited to help you here!

Thanks again!

Hi @mharwood,

Going to my.sonatype.com, then logging in via GitHub (@gmail) ends up with the same error message.
If I log in using my corporate email at my .sonatype.com → no organisation is assigned to me → ideas .sonatype.com == same error message.

Ahh, I see now. To access the Sonatype Ideas portal , you’ll just need to quickly create an organization at my.sonatype.com. For instructions on how to do this, I recommend watching this short video to learn more. It will show you how to create that Organization and that should make it so you can get into the Ideas portal. Please let me know if you need any help!

Thanks for quick reply, so… a feature request for my.sonatype.com :slight_smile:

I see “organisation already exists” - I have no idea who created it, so it would be good to be able to “send request to join the organisation”, as currently I’ll have to look around colleagues who owns it :slight_smile:

I know that when you try to verify the organization that already exists, it does notify the admin on their end, but I’m going to send you a DM to see if we can help figure out who that is more quickly in the meantime!

1 Like