Blob storage and disk usage don't match

I’m using in my organization Nexus Repo Manager 3.41.1 (just upgraded!!) and I noticed a large mismatch between the size reported by “Blob storage” UI screen and the actual size on disk:

while “du” and “df” are reporting (note that NRM runs as a docker mounting /storage as /nexus-data folder:

/dev/mapper/centos–storage-storage xfs 36T 35T 631G 99% /storage

In other words the UI reports roughly 26.56 TB while df/du are reporting 35TB of disk usage… so there is a ~9TB difference (!!)

Since docker blob store is by far the largest one I tried running the following “tasks”:

  • Docker - Delete unused components
  • Docker - Delete unused manifests and images
  • Admin - Compact blob store
    but still no luck…

Also note that I set some “aggressive” (as far as possible) cleanup policies on all docker repositories (hosted and proxy) but I cannot delete much more data. And actually if I could bring down the disk usage to 26TB (as reported by the UI), I would be fine (the disks have 36TB totally available)… my problem however is that we are at 99% disk utilization and I cannot explain why.

What do you suggest? Is there any export procedure to move somehow the blob storage on another server and then re-import them back ? My feeling is that there are “orphaned” docker images that Nexus does not clean up so my wild guess is that if I can export the images, clean the whole /storage/nexus-data/blobs/docker and finally import back the images, such orphaned docker images would disappear (but perhaps I’m wrong)

Thanks for any hint!!

Francesco Montorsi

It looks like you are hitting this open bug. [NEXUS-17740] blobstore Blob count and Total size are sometimes incorrect - Sonatype JIRA
You can watch it to see when we work on fixing the bug and vote on it to help us prioritize.

right good point - it might be the same…