Blob stores consuming disk space

Hi,

We recently had diskspace issue on our server and looks like the blob stores are consuming the whole space (1 TB). I was handed over this server very recently and now when I try to set up clean up tasks the blobDelete (type: Admin-Compact blob store) task does not seem to work and the status remains “Cancelling” when we try to manually stop it.
I pressed the STOP button of the task, but the status has not changed.
Also, the new space we added now is also being consumed very fast and we will land in same issue very soon. Is there a way to manually cleanup the space from OS level as this seems to be not working? I also tried deleting older components but the space does not seem to be released back.

Please let us know how to keep disk space usage in control as these scheduled tasks doe not seem to be working. I tried attaching the system information but looks like I am not allowed to. Please let me know if you require any further information.

Thanks in advance.

1 Like

The Compact blob store task solely will not free up any space. First you need to delete some content either manually, using cleanup policy, or other tasks (Delete unused components, Delete unused SNAPSHOTS, Delete SNAPSHOTS, Delete incomplete uploads) - this will soft-delete blobs. After you’re done soft-deleting, run Compact blob store task that will actually hard-delete blob and that will free up your disk space. If you will be still running into issues when running your tasks, please share your logs. Most stuff is logged in nexus.log (and the console), but tasks also keep their own separate logs that contains more details. You may be interested in our Storage Management Guide.

2 Likes