Blobstore in a network storage


I have problem with blob store in network storage. I have installed Nexus Repository 3 (version “OSS 3.22.1-02”) on a windows server 2012 r2 standard.

I would like to create a new blobstore in another server using UNC path (\server\path\to\folder) but it doesn’t seem to work. I don’t want to store my releases on the same server than Nexus server (because of the hard drive capacity).

I read that it has to implement NFSv4 to work (Storage Guide), so I configured it and it’s still not working. I tried with the web wizard on Nexus Repository (blob stores > create new blob store) and an error appear:
Unable to initialize blob store directory structure: \BigData\Central\DIT\SE\Dev\Nexus, Cause: \BigData\Central\DIT\SE\Dev\Nexus

(The error isn’t clear by the way…)

I tried next to create the blob store locally and then move it to a network storage following the guide found here : Relocating Blob Stores – Sonatype Support) I specified the UNC path in the “update repository_blobstore…” step.

After these operations I went to the administration of blob store but Nexus tells me that the blob store is “unavailable” (but I notice but the “path” of the blob store has change and is the UNC path).

What am I doing wrong? It isn’t possible to store blob in another server using UNC path (or somethinf similar)

Thank you in advance for your help! :grinning:

UNC paths work, but you need to start them with a double ‘’.


If that isn’t working for you, check the nexus.log. There is likely some permissions problem.

Thanks for your answer! The editor removed one “”… But my path is the same as yours.

After looking at the rights on the “Nexus” folder I noticed a problem. I resolve it so now it’s working.

But it’s weird that we have to use the “hack” of relocating a blob store to make it work. The web wizard isn’t working, even with the appropriate rights.

I always have this error (in nexus.log):

Caused by: java.nio.file.FileSystemException: \\BigData\Central\DIT\SE\Dev\Nexus\blobs\test: An unexpected network error occurred.

I tried with slash and with backslash:

And nothing seems to work, is it a bug?

Thanks for your help!