Bucket exists but is not owned by you


I did the upgrade to the OSS 3.36.0-01 but I can’t connect the S3 bucket for the blobs now. I tested this same user/bucket in 3.29 version and worked fine… so isn’t a permission thing.

I can’t do another upgrade right now… anyone can help me with that?

Thank you.

Hi Antonio,

Please can you confirm how you’re specifying your credentials to your Nexus Repository instance? That is, is it through IAM or directly via the ‘Authentication’ section of the S3 Blob Store Configuration?

If you’re specifying via IAM can you please try via the ‘Authentication’ section using temporary access keys in order to ascertain whether or not it’s an issue with your environment/deployment?


Hi Olu, I’m doing it in the “Authentication” section of the s3 blob store configuration as I did in the previous version with another one.

I put here my access key and secret access. it worked before with the same credentials.


Thanks for confirming. Please can you also confirm that the region you specified in the S3 Blobstore configuration page is the same as the region where the S3 bucket actually is?

Olu Shiyanbade

Yes, is the same and also the machine are in the same region.

Thank you.

Any ideas?


You need more privileges. Here is the minimal privileges for Nexus to manage s3 blob:

  • ListBucket
  • GetBucketAcl
  • GetLifecycleConfiguration
  • GetObject
  • DeleteObject
  • PutLifecycleConfiguration
  • PutObject

You can using a user who has admin privileges to test this via CloudTrail’ log.
Here is the Official Docs: Configuring Blob Stores