Can’t connect to private Azure Artifacts repository, Error 404 using valid credentials

Hi, I am trying to use Nexus as a mirroring server to a Azure artifacts repository, which requires authentication, but I’m not able to achieve this. I tried different things, including using HTTP Auth settings for the proxy, with and without “Enable Cookies” and “Enabled circular redirect”, but I always get an error like:
UNKNOWN com.sonatype.nexus.repository.nuget.internal.NugetFeedFetcher - Status code 404 contacting https://pkgs.dev.azure.com/**************/nuget/v3/index.json/Search?$skip=0&$top=80&searchTerm=’’&targetFramework=’’&$filter=IsLatestVersion&includePrerelease=false&semVerLevel=2.0.0&$orderby=Id”

(Note: I can access the Azure repository directly without going to the Nexus proxy, so its not a problem with the Azure respository)

Is this a supported scenario currently? Do I need to configure something else?

Thanks,
Nelson

@nelsonduvall What URL are you using to connect your client to NXRM?

@jstephens I’m using an URL like http://nexus.domain/repository/nuget-proxy/ where the nuget-proxy is the proxy configured to the Azure repository.

1 Like

Hi @jstephens , any help with this?

Are there any news or solutions. We struggle with the same problem:
Try to proxy a azure devops artifact repository without success. We tried it with a private feed (with credentials) and also a public feed but does not work in anyway.

@jstephens we are evaluating the possibility to have our DevOps artifacts package also to be published in the on-prem Nexus registry. Is nexus team aware of the issue posted in this thread, where could we find the technical support could help us to solve this issue?

Does Azure require pre-emptive authentication?

In terms of technical support, if you have a support contract you should file a ticket.

I have this working using Nexus Repository 3.38.0-01.

In the below example, I’ve substituted some real world values as follows:

To get this working I had to:

  1. Log into Azure DevOps (pretend my username is bob@test.com) and create a Personal Access Token (PAT) with the scopes: Packaging (Read) - access this at https://dev.azure.com/my-ado/_usersSettings/tokens

  2. Log into Nexus Repository as Admin and create a new Repository as follows:

I could then access this URL successfully against my Nexus Repository:
https://my-nexus.tld/repository/nuget-azure-devops-proxy/index.json

1 Like