Can't delete folders through UI

I am running OSS 3.19.1-01. A user is trying to delete a folder on a Yum repository. Pressing the “Delete folder” button in the UI pops up a message saying “The folder is now being deleted in the background”. However, the folder never gets deleted. There is no indication in the logs either that a background task has been created or that the delete has been attempted. Is anyone else seeing this problem?

we using 3.22.1 everything works fine, just tried to delete

I am having the same issue trying to delete a folder in a RAW repo, i am on 3.22. Apparently my folder has a backslash instead of a slash and the HTML view does not work either. Any solutions?

Has anybody found a solution?

I have a folder that was accidentally added with backslashes and it refuses to delete, even though it says it’s being deleted in the background.

I found the solution - I ran the “Repair - Rebuild repository browse” task against the repo a couple of times and it removed the unwanted folder.