Can't save password of LDAP binding account in LDAP connection setting

We are having issue that new user(s) added to global user groups can’t login to Nexus because Nexus server doesn’t seem to bind with LDAP server in 3.22.1.

Before we upgraded to Nexus 3.22.1, password of account to bind LDAP server was saved in LDAP setting. But after upgrading to 3.22.1, password in LDAP setting is DELETED. Even though I typed in the password and clicked “Save” button again, password is automatically deleted a couple of second late and this field is empty.

Users who were binded before, they are still able to login to Nexus. So this issue impacts to the new users added to global user groups after the upgrade.

Is this a bug on 3.22.1 or a new feature on 3.22.1? Or any solution on this?


There were recent changes that require you to re-enter the password upon changing settings when configuring the LDAP server.

Hi Matthew,

Thanks for your response

After upgrading Nexus 3.22.1, password field was empty. We didn’t even change the password. Even though I typed the password because password field was empty, this filed was automatically cleared after a couple of seconds. I even tried to type the password several times as soon as I see the password field is cleared, but no luck. Based on your response, I was expecting the prompt to re-enter the password, but there was no prompt either.

Can you please provide me in more detail on this including any reference?


Hi Matthew,

I see the recent change that require to re-enter the password, but I also see that it is not consistent thru all our Nexus servers. We are running 6 Nexus servers, and 1 server doesn’t ask to re-enter the password.

The issue I see here is that newly added account to global user group is not updated to Nexus server. So, this new users can’t login. I thought that the issue was because the password of LDAP disappeared, but it seems to be something else other than this. When I run “verify user mapping”, I am getting an error saying “Operation failed as server could not be contacted”. This LDAP setting hasn’t been changed at all, and I would like to ask what has changed in Nexus 3.22.1.


This issue is resolved and issue was due to global user groups setting. Thanks for the help, Matthew.

I’m having this same problem. Can you be more specific about what the solution was?

There was also a bug discovered, assuming this is your specific issue the 3.25 release branch has been forked and we’re waiting on the last fixes to land before a releasehappens -

In the mean time, LDAP can also be configured with the REST API

HI Mark,

Once password was saved, it disappears after a few seconds so the password field is empty. But I don’t know if this is a real issue. My issue was that some user groups weren’t retrieved due to LDAP query, not the password field being empty.

I hope this helps.


we are using nexus 3.22.0-02 is there any documentation of enable LDAP step step
first step is ok . we are struck in user and group options
anyone have idea for this

thanks for the info.