Database backup for version 3.8.0

help

#1

I am currently running v3.8.0 with the Distribution Archive and wanted to upgrade to v3.15.1 (latest) as well as use docker this time.

I was going through the documentation on how to backup the blobs and db but in 3.8 I cannot find this task type “Admin - Export databases for backup” (mentioned here), but I can find though the “Export configuration & metadata for backup”.

How do I achieve this, is there another way of backing up the db in 3.8?

Thanks in advance for your help!


#2

@altin.ukshini

I recently did an upgrade from version 3.2.1 to 3.15.1-01. I backed up all the contents of the ${Kara.data} / the data directory of the instance.

In case of a rollback the backed up data can be used. The upgrade was smooth hence I don’t think it should lead to a rollback.

Regards,
Allan Selvan


#3

@atselvan

Well, I managed to restore the .bak files as specified in the docs. Users and passwords all restored, I did also copy the old blobs folder to the new data dir that I mounted as a volume in docker, thus I can see my repositories and content in them, however, when I try to access (download) an artifact I get:

javax.servlet.ServletException: org.sonatype.nexus.repository.storage.RetryDeniedException: Reached max retries: 8/8

and

org.sonatype.nexus.repository.storage.MissingBlobException: Blob artifacts@96A04123-29A4DEE5-EE8E421D-25F8249F-0A17A87C:e5ee7971-2cd8-47ef-ab55-d3e929f96c9f exists in metadata, but is missing from the blobstore

Just in case, I tried rebuilding indexes but it didn’t help.


#4

Shoot, I had a blobstore outside of my blobs folder. Had to relocate it. Everything working fine now!
Thanks for your help! :slight_smile:


#5

Awesome, good to see that it worked for you :slight_smile: