Deprecated Plugin is working whereas Nexus Platform Plugin is not working for Jenkins 2.X


#1

Team,
we have Jenkins version 2.183.3 in our testing environment .we had installed both Nexus-IQ Plugin 2.16 as well as Nexus Platform Plugin 3.5xxxxxx. we had credentials issue with Nexus-IQ Server .Thus we tried to enable /disable the plugins and try it out .Please check out these 2 cases and let me know your insights …
1.)when we enabled Nexus Platform plugin(3.5) ,the build Failed with a error saying "http : Invalid credentials "as in global settings for CLM Server ,it wont ask for any credentials .
2.)when i enabled Nexus-IQ plugin(2.16 - deprecated) ,it worked fine & scanned all artifacts ,uploaded all artifacts using nexus artifact uploader plugin .

As far as compatibilty view, IQ Server 56 is installed on our end & that is not compatible with Jenkins version 1.X through 3.0 . but is compatible with Jenkins plugin version 3.3 onwards …
Thus making situation even weirder …

Please let m know what is the suitable & feasible plugin that can be used & how …

Thanks,
Nagashree.B


#2

This sounds like a request for support with a licensed version of Nexus IQ Server? If so, you should have one of your support contacts raise a ticket in our support system at https://support.sonatype.com.

Regards,

Rich