Error in retrieving record while accessing npm-registry/npm


We are using Nexus Repository Manager OSS 2.14.9-01 (and I understand we need to update to latest version) but all of a sudden, we are getting below error while accessing the ‘content/repositories/npm-registry/npm’ path:

# 500 - Error on retrieving record #3:4 (cluster: default)

Here is the truncated stack trace:

2024-02-14 12:31:34,984-0800 WARN [qtp25899251-118683] anonymous - Error on retrieving record #3:4 (cluster: default) [client=,ua=curl/8.1.2,req=GET]
com.orientechnologies.orient.core.exception.ODatabaseException: Error on retrieving record #3:4 (cluster: default) at com.orientechnologies.orient.core.db.document.ODatabaseDocumentTx.executeReadRecord(

The npm-registry is a proxy repo (npm-mycompany points to this). I can still access other files from the directory but just the ‘npm’ is throwing error.

I have already tried rebuilding the hosted npm metadata but didn’t help. Also tried searching similar issues here in this community but couldn’t find anything.

Could you please help me figure out what could be wrong?

Thank you!

It could be that NPM has changed something on their end and the request your antiquated version of Nexus is sending when proxying is no longer valid. My first suggestion would be to upgrade to a newer version of nexus and try again.

Likely this is some sort of database corruption but its difficult to tell from the excerpt.

Thank you both. We are planning on upgrading the nexus. So hoping that should fix it.

Just wanted to share that I deleted and recreated the npm proxy registry and that fixed the issue. As a long term solution, we are working on upgrading the nexus.

1 Like