Even your communityboard is bad


Well after I have set up a nexus server I am struggling for 2 days to do a simple maven deployment up and running… I get a 401 error. But because I am not allowed to send the logs or something else in this useless board well I ask my manager to stop the Nexus project and lets find something else which works like designed.

Thanks for your bad support.


Welcome to the Community. Looks like you joined 30 minutes before posting this topic. What error were you seeing during that time that prevented you from posting logs?

A 401 error suggests that you were having issues authenticating.

Were you getting this error when attempting to navigate your browser to the application, or when using maven to pull or push components?

The following pages all address installation of Nexus Repository Manager in formats which appeal to different learners:

There is also an older blog post which specifically addresses how to diagnose 401 errors:

Hi Andres,

Yes I am not in such a good mood after this weekend struggling with Nexus OSS3

I have posted my question on stackoverflow:

Maybe you can have a look at this link ?
Help would be appriciated.

I have checked this link but it didn’t help me out:

I have also followed this tutorial:

But this also didn’t help me.

Wow…and suddenly it works !!
After 2 days I have my first deployment.

Glad your problem was resolved! Did you make any changes?

Yes thanks, I have changed the nexus id with the sligro id in the mirror and that does it.
Stupid newby error
Thanks for support

by the way if you look at stack overflow then you can see my post which I was try to upload to this board but didn’t succeed.

I did take a look at it. So you tried to upload the same content and it threw an error? I will take a look a it. Do you remember the error you saw when posting?

Yes it says I was not allowed to upload 2 links, but I didn’t upload any link. Only XML code and error log lines.

In the error files there are some links in the text, maybe that was the problem ?

That is interesting. Yes, I think the spam controls flagged it, unable to discern the difference. Uploading as a file might have worked there. I might look at adding some posting suggestions that try to mitigate that. Sorry it was a poor experience for you! Glad it all works now.

Thanks for your quick response.
Yes I have added my first jar to the snapshot repo in the meantime. No I have found a solution for to pull the jar out of nexus but thats for tomorrow. I gonna take a bottle of beer.
Have a nice sunday.
Kind regards