Gitlfs-hosted/info/lfs from HTTP 405


#1

I’m attempting to configure GitHub and NXRM OSS to support my large file pushes to be published to NXRM. I tried to the best of my ability to following the instructions stated in the URLs:

https://help.sonatype.com/repomanager3/git-lfs-repositories

It’s apparent I don’t have something configured right.

Three things:

  1. I’m being prompted to enter my login credentials. How can that be prevented?
  2. The push fails with a 405 error which seems to be affected by the LFS locking API, yes?
  3. What must be done to the GitHub hosts side to support what I’m doing?

$ git add . ; git commit -m “add change” ; git push origin
[development be4917e] add change
1 file changed, 0 insertions(+), 0 deletions(-)
create mode 100644 application0001.war
Remote “origin” does not support the LFS locking API. Consider disabling it with:
$ git config lfs.http://localhost:8081/repository/gitlfs-hostsed/.locksverify true
Client error: http://localhost:8081/repository/gitlfs-hosted/info/lfs from HTTP 405
error: failed to push some refs to ‘git@que.stc.local:mp/webserver.git’


#2

You need to add “info/lfs” onto the end of the repository URL:

git config -f .lfsconfig lfs.url http://localhost:8081/repository/gitlfs-hosted/info/lfs

Regards,

Rich


#3

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)


#4

Hello! :slight_smile: I got the configuration to work. I misunderstood the step or process for creating the “gitlfs hosted” repository. Tonight, as I was browsing the create repository “recipe” list, my eyes noticed “gitlfs (hosted)”. BOOM! Once I created a repo from that template everything worked. I still would like to know a way to get around being prompted for my credentials. The only way I found to do so was to use this git command to configure the .lfsconfig file.

$ git config -f .lfsconfig lfs.url http : //user:passwd@ localhost:8081/repository/repo-lfs/info/lfs

Question: When I went to look at the file on the NX host repo. All I see is a folder and file with a long string of characters. I know this is the pointer file. But I PUT 3 tracked files and from GitHub they all reference the same string. This is expected?