How to create a yum proxy repo for CentOS 8 EPEL

I created a YUM proxy repo for Index of /pub/epel/8/Modular/x86_64 (CentOS 8 EPEL), but when i run “dnf repolist enabled” on my CentOS 8 host i get a package count of 0 for the EPEL repo.

I can not see errors in nexus log and nexus shows “Online - Remote Available” as repo status.
So everything looks fine.

Any ideas?

Maybe not helpful, but I added this repo to my Nexus Repository Manager and was able to list all the packages, but from a CentOS 7.7 installation. I don’t have a CentOS 8 install readily available right now.

I’m on nxrm 3.22.1 and used

https://dl.fedoraproject.org/pub/epel/8/Modular/x86_64

or

https://dl.fedoraproject.org/pub/epel/8/Modular/x86_64/packages

for my URL. I tried both, but I’m not sure which one is working because I’m not sure if the repo data is cached when/if I’m using the wrong URL. I can do further testing, if you can’t get one of the URLs working still.

I could also install CentOS 8 and test, if you think it would be helpful.

I am on nxrm 3.20.1-01 and i get different results, when simply updating the URL in the nexus repo, or when creating a new repo with the desired URL. Maybe remove+re-create is better for debugging.

When i re-create a nexus repo with:
—your second link— (sorry a new forum user can only put 2 links in a message)
then i get a “download report” with “0.0 B/s | 0 B 00:00” and error:
“Zwischenspeicher für Paketquelle »my_centos-8-EPEL« konnte nicht synchronisiert werden, dieses Repo ignorieren.” (german for: dnf could not syncronize with nexus repo).

When i delete that repo an re-create it for:
—your first link— (sorry a new forum user can only put 2 links in a message)
then i get a “download report” with “153 kB/s | 117 kB 00:00” and no error message.
Looks a bit better i think.

In both cases i get the “package count” of 0.

Before each test i did a “dnf clean all” to ensure that there is no local cache interfering.

Using:
https://dl.fedoraproject.org/pub/epel/8/Everything/x86_64/
http://ftp-stud.fht-esslingen.de/Mirrors/epel/8/Everything/x86_64/
results in package count 5.472.

Looks like “Modules” is broken on “all mirrors” (at least all i tested) or nexus is not able to read it, while “Everything”-directory as repo source is working.

Is the mirror broken or nexus?

It looks like there is a bug that prevents this from working: https://issues.sonatype.org/browse/NEXUS-19895

When i try to open your link:

It may have been deleted or you don’t have permission to view it.