Https to the load-balancer, http to the server == mixed content errors


#1

I’ve got Nexus 3.x latest running on the default port and working via an http url to the server name.

We’ve set up an F5 load-balancer config to accept/force https via the url someservice.mydomain.com
it talks over http port 80 to the server’s Apache
Apache passes the request to 8081

<VirtualHost some.ip.in.here:80>
   ServerName someservername.mydomain.com

ProxyPass / http://localhost:8081/

The problem is the web UI shows mixed content errors on .js and most images.

I tried setting Admin > Capabilities > Base Url to the https url (to no effect).
I think we have the header: proxy_set_header X-Forwarded-Proto=http (not https)

Any suggestions how I can fix this?


#2

See link below, you need to have X-Forwarded-Proto=https

https://help.sonatype.com/display/NXRM3/Run+Behind+a+Reverse+Proxy#RunBehindaReverseProxy-Apachehttpd-ensureApachehttpdisloadingmod_sslandmod_headers


#3

Yup confirmed that’s the problem.
Thanks rseddon :slight_smile: