Issues? Or something changed - cannot download artifact without user/pass prompt

Trying to download in a script from maven central using a URL I’ve used plenty before – this fails.

Has something changed? The URL still seems to be in the current docs?

➜ /tmp wget “\?r\=central-proxy\&g\=org.odpi.egeria\&a\=egeria-connector-xtdb\&v\=LATEST\&c\=jar-with-dependencies
–2023-05-09 09:15:25--\?r\=central-proxy\&g\=org.odpi.egeria\&a\=egeria-connector-xtdb\&v\=LATEST\&c\=jar-with-dependencies
Resolving (…,
Connecting to (||:80… connected.
HTTP request sent, awaiting response… 301 Moved Permanently
Location:\?r\=central-proxy\&g\=org.odpi.egeria\&a\=egeria-connector-xtdb\&v\=LATEST\&c\=jar-with-dependencies [following]
–2023-05-09 09:15:25--\?r\=central-proxy\&g\=org.odpi.egeria\&a\=egeria-connector-xtdb\&v\=LATEST\&c\=jar-with-dependencies
Connecting to (||:443… connected.
HTTP request sent, awaiting response… 401 Unauthorized

Username/Password Authentication Failed.

In case it was DNS or local network blocking, I tried from a cloud vm…

Same issue, from

Still the same here - which is making me wonder if this is an intentional change ? Or my bad memory

This is now working again

I’m experiencing the same issue, this started today and have been going for a few hours now.
Seems like using queries like these just keeps throwing “401 - Unauthorized”.
@nigel.l.jones I also tried your link and indeed I get also a 401.
Anyone experience this?
I was thinking that maybe it is related to a recent incident in (Maven Central Status - is down)

Same here. Invalid URLs are correctly returning 404 with a descriptive error message, correct URLs returns 401. Anonymous authorisation also fails.


Same issue.
Guys, can you prioritize this one, if you are going to fix it?

1 Like

Maybe it’s related to this?

As mentioned above by @dudi - this problem has resurfaced in the last week. It worked for a while after initially being reported, but is again broken (presuming the change wasn’t intentional)

Hi all - I have made our team aware of this thread and will let you know of any updates I receive or info related to this issue. In the meantime, please let us know if anything changes. Thanks!

Still no changes

1 Like

I’m also seeing the same 401 error; any update from your team @mharwood ?

Hey @ben.garrett (and all) - thanks for following up. I checked back in with our team about this. It seems like you just want an API to call to download the latest version of an artifact on Maven Central.

The recommendation is to try, for example:

I should note that is something our team does not recommend relying on at the moment.

Thanks @mharwood . To note - we are currently transitioning to While we have a roadmap to ensure API compatibility with, endpoints will be prioritized by usage and may not be available in the near term.

I would suggest downloading and parsing the maven-metadata.xml from to find the latest version until has the appropriate API capabilities for anything that is mission critical.