.lfsconfig setup questions


#1

Setup:
NXRM 3.13.0
GitHub (web)
Jenkins 2.121.3

My .lfsconfig contains:
$ cat .lfsconfig
[lfs]
url = http:// admin: admin123 @ localhost:8081/repository/kevin3-lfs/info/lfs

My default gitconfig contains:
c:\Program Files\Git\mingw64\etc>type gitconfig
[credential]
helper = wincred

When I execute PUSH/PULL from a Git shell, I am not prompted for any credentials. That’s what I expected. When Jenkins executes a job it connects to NX using the admin account.

Now if I remove “admin:admin123@” from the http string in the .lfsconfig and set the Git credential.helper to wincred. I’m not prompted to enter credentials from the Git shell. Good. However, the Jenkins job just spins and eventually times out to abort because it can not authenticate to NXRM.

Is there a Jenkins/Nexus plugin available to configure an account to authenticate from Jenkins to the Nexus Git LFS repo so no user credentials aren’t exposed in the .lfsconfig file?


#2

How’s this as an alternative solution? I concluded that Jenkins is authenticating to NX with the “anonymous” account. It’s interesting that the default role settings (read/browse) for this account does not make the connection to execute the NX/Git checkout (pull) from the the NX repo to capture the LFS files. So I created another role with full privileges (read/browse/add/delete/edit) from the NX Git-LFS repo. Added that new role to the anonymous account. Now the NX/Git checkout works.


#3

Solved: see last post: Gitlfs-hosted/info/lfs from HTTP 405