Missing LDAP Realm option, running OSS 3.18.1-01

Just installed Repo Manager 3.18.1-01

Following LDAP to setup LDAP.

On step, “Select the LDAP Realm and add it to the list of Active realms on the right”

This is not present in the list of available Realms. How do I get it to be in the list so I can follow these instructions?

See attached screen.

I have verified the nexus-ldap-plugin .jar is present in my install directory, and the plugin is listed in nexus-oss-feature-3.18.1-01-features.xml

I have found this SO question from 3 years ago which seems similar. They concluded that this was a bug in a particular version of Nexus Repo Manager… surely it is not still though?

There are no ERRORS in nexus.log or mention of LDAP in any of the logs (grep -iR ldap *) .

There are no known issues that would cause the LDAP realm to be missing from a new install. The fact that there are no ldap messages at all in the log suggests something is wrong with the installation, you should have seen messages like these:

2019-10-08 15:30:14,864-0500 INFO [FelixStartLevel] *SYSTEM org.sonatype.nexus.extender.NexusBundleTracker - ACTIVATING com.sonatype.nexus.plugins.nexus-ldap-plugin [252]
2019-10-08 15:30:14,906-0500 INFO [FelixStartLevel] *SYSTEM org.sonatype.nexus.extender.NexusBundleTracker - ACTIVATED com.sonatype.nexus.plugins.nexus-ldap-plugin [252]

Thanks @rseddon. We have installed using the tarball installation instructions here: Installation Methods. We have only done minor changes to the config to enable writing to a different data-dir (which seems to be working fine).

Do you have advice I troubleshoot these missing messages. There are many other ACTIVATING / ACTIVATED lines for loading plugins, but this one is just missing.

The Stack Overflow article I linked above mentioned dropping into the “karaf console” and finding some messages. I don’t know how to do that though. Is this a good next step? If so, do you know how I would do that?