[Newbie alert Fetching takes too long, and timeout

Hello all,

I am running “Sonatype Nexus Repository Manager version OSS 3.29.2-02”, and yeah, I know it is quite old version on my legacy system.

We have a Gitlab CI/CD pipeline running which call maven, and maven calls Nexus
For some pipeline, the pipeline ends up with following timeout error

ERROR: Job failed: execution took longer than 1h0m0s seconds

The gitlab server and Nexus server sit on the same AWS region so downloading from Nexus to Gitlab should be very fast. However, it is very very slow actually.

Our Nexus server run on a docker (on Ubuntu/AWS).

I’ve tried to run htop on the host machine. It looks fine.

This is the raw log I’ve found in my Nexus server

tail -f /opt/sonatype/sonatype-work/nexus3/log/nexus.log
2023-03-08 07:12:15,859+0000 WARN [qtp822646151-20276] readonly org.sonatype.nexus.repository.maven.internal.orient.MavenProxyFacet - Exception org.apache.http.conn.ConnectTimeoutException: Connect to repo1.maven.org:443 [repo1.maven.org/] failed: connect timed out checking remote for update, proxy repo maven-central failed to fetch net/logstash/logback/logstash-logback-encoder/7.0.1/logstash-logback-encoder-7.0.1.pom, content not in cache.


2023-03-08 07:20:00,003+0000 INFO [quartz-8-thread-19] *SYSTEM org.sonatype.nexus.quartz.internal.task.QuartzTaskInfo - Task ‘Storage facet cleanup’ [repository.storage-facet-cleanup] state change WAITING → RUNNING


2023-03-08 07:34:54,583+0000 WARN [qtp822646151-20274] *UNKNOWN com.sonatype.nexus.plugins.outreach.internal.outreach.SonatypeOutreach - Could not download page bundle
org.apache.http.conn.ConnectTimeoutException: Connect to links.sonatype.com:443 [links.sonatype.com/, links.sonatype.com/, links.sonatype.com/] failed: connect timed out

Please advise what I should do?
Is that upgrade to the latest stable version necessary?

Thanks in advance for any helps!

This is a problem with your network preventing Nexus from talking to remote servers.

In the admin part of the Nexus UI there is a proxy server configuration in System > HTTP

Thank you. Let me try the proxy setting.