Nexus 3.18.1 initial login dont works


I tried to install Nexus in the latest version. My problem is that i cannot login with initial password from admin.password. I added with the api a new user also as nx-admin still dont works. For every login that i try with a user i become this error message.

Uncaught TypeError: Cannot read property ‘forEach’ of null (http://ip:port/static/rapture/nexus-onboarding-plugin-prod.js?_v=3.18.1-01&_e=OSS:1)

Which browser are you using? At first glance I don’t think it’s a supported browser: System Requirements

Is use generelly Chrome. Also tried Firefox, Microsoft Edge

This looks like a bug to me, we’ll create a ticket for this bug. Are you an admin user? There is a new onboarding wizard that should show up on first login after upgrading.

I am admin user. The strange thing was that the installation wizard is only opened when i restarted the server. Because i restarted i cannot proceed the wizard. This is every time the same.

This shows me when i stop the nexus repository service directly after shutdown/stop.
I already tried the newest version but still the same error. Currently i have 3.18.0

When i log in this is the log from the console:
2019-08-28 16:58:39,847+0000 WARN [qtp1965102525-53] UNKNOWN - (ID 18a8972d-9897-40b9-b1d2-07177eb0f21e) Response: [403] (no entity/body); mapped from: org.apache.shiro.authz.AuthorizationException: User is not permitted: nexus:

I think, at this point, it would be best to file an issue for this in the ‘dev - nexus’ project at, so we can check your logs.

Created isssue:

Evidence was provided that showed NXRM was not receiving HTTP POST requests to the /service/rapture/session endpoint and possibly others. NXRM could be accessed from the host where it was running ( a Debian VM ) just fine. There is some software on the Windows 10 host machine where every web browser had certain requests block. Software like McAfee Web Gateway is usually to blame in these cases.