Nexus Artifact Uploader - "Read timed out"

We’re not using Maven, but are utilizing the Nexus Artifact Uploader plugin for Jenkins. 9 of 10 builds, artifact successfully uploads (large file ~1.4GB) to a Nexus Raw repository (also occurs when using Yum repository). Half of those times, the Jenkins project will fail, even though the large artifact successfully uploads anyway. Cannot determine where to increase a wait timer in Nexus, Jenkins nor Docker container - Or is solution more complex than some timer setting…? From Jenkins console output:
09:40:06 90 % completed (1.3 GB / 1.4 GB).
09:40:13 100 % completed (1.4 GB / 1.4 GB).
09:41:13 Failed to deploy artifacts: Could not transfer artifact ……. : Read timed out
09:41:13 ERROR: Uploading file ………failed.

Notice the time stamp between when the large file completes upload, and the Failed/ERROR time stamp is exactly 60 seconds. This time difference is consistent on every failed build. Just need to know where the 60 second timeout can be increased.

That’s not a Sonatype plugin, so I can’t tell you for sure… but taking a quick look, it uses wagon-http for upload, and it is a pretty old version:

I don’t remember when the timeout for the wagon was bumped to 30 minutes default, but if this version has the old 60 second timeout you might be able to use the “maven.wagon.rto” system property to adjust it:

Thanks Rich. On Jenkins server, I edited /etc/sysconfig/jenkins file (jenkins startup parameters), added the maven.wagon.rto setting to Java options, like this: JENKINS_JAVA_OPTIONS="-Djava.awt.headless=true -Dmaven.wagon.rto=180000" Restarted Jenkins, and ran another test job. It still failed upload after 60 seconds. Am I not changing the read timeout in the correct place?