Nexus failed to start - IllegalArgumentException: null


I’m using nexus-repository-manager version 3.40.101-2 on a debian machine (5.18.5-1).
Java is version 8.

Recently nexus stopped to start with the following error in the nexus.log:

root@AppArtifactory:/opt/sonatype/sonatype-work/nexus3/log# cat nexus.log
2022-07-17 12:18:26,646+0000 INFO [FelixStartLevel] *SYSTEM - start
2022-07-17 12:18:26,963+0000 WARN [FelixStartLevel] *SYSTEM org.apache.karaf.features.internal.osgi.Activator - Error starting activator
java.lang.IllegalArgumentException: null
at java.util.concurrent.ThreadPoolExecutor.(
at java.util.concurrent.ThreadPoolExecutor.(
at org.apache.karaf.features.internal.osgi.Activator.doStart(
at org.apache.karaf.util.tracker.BaseActivator.start(
at org.apache.felix.framework.util.SecureAction.startActivator(
at org.apache.felix.framework.Felix.activateBundle(
at org.apache.felix.framework.Felix.startBundle(
at org.apache.felix.framework.Felix.setActiveStartLevel(
2022-07-17 12:18:27,024+0000 INFO [FelixStartLevel] *SYSTEM ROOT - bundle org.apache.felix.scr:2.1.30 (55) Starting with globalExtender setting: false
2022-07-17 12:18:27,028+0000 INFO [FelixStartLevel] *SYSTEM ROOT - bundle org.apache.felix.scr:2.1.30 (55) Version = 2.1.30

Is this a normal error message or is something wrong?

Thanks in advance

Recently I’ve came across exactly the same issue it was running for months and suddenly stopped. Without success yet.

I’ve completely removed java from this machine and replaced every karaf related lib, still without success. Weird thing is that i’ve downloaded a fresh nexus tar from website and tried to run it and faced the same issue on this machine. I’ve completely copied whole nexus instance and run it on another container and worked without any problems, so in my opinion it is more system related than nexus itself. But if you will magage to find the issue it would be great

1 Like

I’ve found a workaround, not a solution.
I swapped regular openjdk-8-jre to openjdk-8-jre-headless and it worked, still don’t know why, but it woks without a flaw.