Nexus.log does not recreate itself

Hi All, New (like NEW) Nexus user here taking over from a person that left…

Anyway was getting a 500 error, in nexus.log it was reporting that there was not enough free disk space (said it needed 4GB, was only about 1.5GB. I cleaned up disk space and then was getting errors about it not starting at all, I removed the nexus.log file it had been writing to and restarted expecting it to recreate that log file, but it did not and now I’m not getting any log. I do get a jvm.log and the log paths in there all look right but still no log file. I tried restoring a day-old file from zip and a blank file… nothing… Any help or suggestions what to look at would be greatly appreciated!


Not sure what’s happening on your system, but you might take a look at the logback configuration file in your installation to see if it’s been customized somehow. It should be in your installation directory under etc/logback/logback.xml.

Do you know if there is a default version I can compare with? I’m fairly sure there’s been some customizations. Every night at midnight the nexus.log and request.log are compressed and new ones are started (no idea if this is default of not…) I did remove the zip files that were in here older than 30 days so there wasn’t anything cleaning these up automatically.

I believe the default is this nexus-public/logback.xml at main · sonatype/nexus-public · GitHub

ok thanks, will take a look. for sure got to be something in the config, I had a “fresh” download folder and tried running it and it at least did create all of the log files the installation i’m trying to fix only creates a jvm.log.