Nexus not silently default to /library when proxy docker.io


#1

Hi,

I configured a proxy for docker hub, the remote url is set to https://docker.io. According to Pull Images of Nexus document, the following command does not works here:
docker pull :9090/ubuntu
I got :
Error response from daemon: manifest for :9090/ubuntu:latest not found
if I changed to (added library):
docker pull :9090/library/ubuntu
it works well.

That is, Nexus is not silently default to /library here if no namespace provided.

What is wrong with my configuration?

Nexus version: 3.15.2-01

Thanks for your help!


#2

wrong formatted, the url should be: host:9090


#3

Try proxying https://registry-1.docker.io

If that doesn’t work can you relay your Docker Index?

Full doc here: https://help.sonatype.com/display/NXRM3/Proxy+Repository+for+Docker


#4

Tried again, It works by following the docs to set remote url to https://registry-1.docker.io and select Use Docker Hub

Thanks for your help!