Nexus Proxy to github private packages giving 404

We had the proxy setup in Nexus connecting to Github repo wherein we are hosting our organisation private packages. Things were working fine but on August 3,2022 , we started facing issue wherein nexus was not able to fetch packages from Github repo and was giving 404.
We even tried creating our own individual user account in github by creating new personal access token which provide permission to download the packages but still we were getting same error.
Reference to Error -
ERR_PNPM_FETCH_404 GET Not Found - 404

When installed using pnpm install, we were getting same error of 404 Not found along with this message - No authorization header was set for the request

On August 9th - Things started working fine though we didn’t do any changes on Nexus side.

Nexus Version currently used - 3.38.1

We even did our cache invalidations to see if it helps but didn’t see any positive results. We tried checking our logs and didn’t find any thing suspicious leading to this issue.