NEXUS Repository 3 - YUM Hosted - No metadata for package

Hello Team,

I need some help to understand an issue with my Nexus Repository OSS v3.
I created a YUM Hosted repository to host default repo from a Redhat CDROM.
So i used CURL to post all my RPMS from a local folder, structured as described below:

RPMS
->8
---->AppStream
-------->Packages
--------> repodata
---->BaseOS
-------->Packages
--------> repodata

After upload i can find same structure in my repository.
When i perform a yum update command, repo are correctly detected and no issue appear.

When i try to install nginx package,for example, my system return :
No available modular metadata for modular package

and the install stop.

There are my tries:

  • Tested with repodata folders from CDROM
  • Tested without repodata folder, nexus create one as expected after 60sec
  • Tried to force rebuild from tasks menu (I can see in log process run smoothly without error)

Anybody had a similar issue or some knowledge to help me ?

Thanks.

RB

Ok i think i find the issue.
It seems the metadata problem only appear when i need to install a “module” rpm.
In my repodata folder on my nexus repo, it miss module.yaml.gz.

I tried to upload it manually but nexus did not use it because it’s not referenced in repomd.xml :confused:

I continue my investigation.

RB

They aren’t currently supported - [NEXUS-22160] Yum support for modules.yaml - Sonatype JIRA