Nexus Repository Manager HA-C issues


#1

Hi Everyone,

A few months back my team and I tried running Nexus Repository Manager Pro as an HA-Cluster. During our tests everything worked fine but when we migrated the system to production the HA-Cluster had some severe issues which lead to a crash. We immediately switched back to our old Nexus server (Windows based) and a few weeks later we just went ahead and migrated the old system to a single instance of Nexus Repository Manager running on RHEL7.
My team is questioning the HA-C Feature eversince and we’re not quite sure if we should try to enable HA-C again with the latest version 3.18.
We have a lot of developers depending on the Nexus Repository Manager and a HA-C would be ideal since a crash of the single node would stop the development in our company.

Is anyone running Nexus as an HA-C? If you do, what’s your experience with it?

Cheers,
Marco


#2

Hey Marco,

Thanks for taking the time to post this. I know there were some customers who had issues with HA-C in earlier versions, but I believe most of those issues have been resolved in 3.18.

Let me poke around and see if we have any other customers that can share their experience with 3.18.

Cheers,
Nick


#3

Hi Marco
We use HA-C on RHEL7
We’ve had stability issues in the past (eg replication issues and nodes dropping out of the cluster) but we’ve been running 3.16.2-01 for a few months now and it has been a lot better - so I’d recommend running a test that or anything newer

Victor


#4

Agree with @vgavin. We are running a three node HA-C 3.16 cluster on RHEL7 and apart from the odd small issues that are slowly getting fixed up (mostly nothing functional just things like odd logging etc.).

I did do a trial on an early version of Nexus 3 HA-C which had all kinds of issues but when I revisited and implemented a 3.15 cluster all these issues were gone.