Nexus Repository Possible Index Corruption

Hi All,

Currently running a Nexus 3:3.27.0 instance as a docker image. It’s deployed in an offline environment due to restrictions. It has several repositories, including an NPM proxy repository so machines in the offline environment can download packages. I do keep a copy of the image on an machine with internet access.

In order to update new packages in the repository, I will occasionally pull these packages from the machine with internet access before porting the entire nexus-data folder to be mounted in the offline server. It’s a complete replacement in regards to the nexus-data and it has worked well for a couple of months until recently.

I attempted to download several packages, for example, react-media-player and Plyr to facilitate playing training videos. I’m able to successfully download Plyr into the Nexus system, but unable to do so for react-media-player. There are instance of other npm packages that are unable to be downloaded as well. Creating a new repository and blob store results in the same error.

I have ran the repair tasks in the following order:

  1. Reconcile component database from blob storage
  2. Reconcile npm /-/v1/search metadata
  3. Rebuild repository browse
  4. Rebuild repository search
    Unfortunately, despite them returning an ‘OK’ status, I’m still unable to download certain packages.

To circumvent this problem, I had to create a new Nexus instance to download this packages in order to proceed on with development work. However, this isn’t ideal as I would need to maintain two separate Nexus images.

The error returned is error 500. I’ll edit in the complete logs as soon as I can.

Hoping to be able to fix the original nexus issue, if not, being able to port the new repository into the original nexus will be a suitable alternative.

Appreciate any advice on this matter.

Are you a licensed user? If so you should have the import/export functionality available to you which may work better (Repository Import). I’d also recommend reaching out to your support contact for additional help, this sounds like there could be a bug that needs to be looked at and support is the best way to get help.

If you aren’t a licensed user, maybe the logs will reveal something. It might be worth opening up a JIRA ticket if you can provide good reproduction steps.