Nexus Uploading File Error

integrations
release-notes
training
learn
help

#1

Dear Friends,

When I want to upload a file in my repository I got the error below. If I want to upload small size files, I can upload successfully. I would like your emergency support.

Danger: Operation failed as server could not be contacted

Version: Sonatype Nexus Repository ManagerOSS 3.15.1-0

Thanks in advance.


#2

Is there a reverse proxy such as nginx or apache running in front of Nexus? If so, is our recommended configuration being used?

https://help.sonatype.com/display/NXRM3/Run+Behind+a+Reverse+Proxy


#3

Hi,

I’m getting same error using oficial Docker image for v3.15.2-01.
I’ve tried using Allow Redeploy policy, with no luck. Nginx settings is as follows.

server {
    listen                      443 ssl default_server;
    server_name                 <my-domain>;
    client_max_body_size        1G;

    ssl_certificate             /etc/nginx/ssl/<my-certificate>;
    ssl_certificate_key         /etc/nginx/ssl/<my-certificate_key>;
...
    location /nexus {
        proxy_send_timeout      120;
        proxy_read_timeout      120;
        proxy_buffering         off;
        keepalive_timeout       5 5;
        tcp_nodelay             on;

        proxy_set_header        X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header        X-Forwarded-Proto "https";
        proxy_set_header        X-Real-IP $remote_addr;
        proxy_set_header        Host $host;
        proxy_pass              http://nexus:8081/nexus;
    }
}

This is all log viewer records:

2019-03-18 20:57:35,843+0000 INFO  [qtp2062979933-287]  admin org.sonatype.nexus.coreui.internal.UploadService - Uploading component with parameters: repository="maven-releases_s3" format="maven2" groupId="com.google" artifactId="chrome-driver-win" version="72.6" 
2019-03-18 20:57:35,843+0000 INFO  [qtp2062979933-287]  admin org.sonatype.nexus.coreui.internal.UploadService - Asset with parameters: file="chromedriver_win32.zip" extension="zip" 
2019-03-18 21:00:00,006+0000 INFO  [quartz-3-thread-20]  *SYSTEM org.sonatype.nexus.quartz.internal.task.QuartzTaskInfo - Task 'Storage facet cleanup' [repository.storage-facet-cleanup] state change WAITING -> RUNNING
2019-03-18 21:00:00,009+0000 INFO  [quartz-3-thread-20]  *SYSTEM org.sonatype.nexus.quartz.internal.task.QuartzTaskInfo - Task 'Storage facet cleanup' [repository.storage-facet-cleanup] state change RUNNING -> WAITING (OK)

Any clues?

Thanks


#4

Hello, i’m also facing the issue, but regardless from an artifact size, we do not use reverse proxy to connect to the repository, could you give any suggestions? Thank you


#5

More details would be needed… nobody can help you without that. What is the Nexus Repo version? What type of upload is failing? What is seen on the client side when it fails? What does the nexus.log file show?