No more menus in web ui, even for admin


I discovered today that I can’t access my Nexus OSS 's web interface.
Or rather, that I can access it but it has no menus anymore.
It looks like an anonymous / restricted access, even with admin user.

I checked my existing users following this documentation:

I only read data, did not change anything in the DB.
I verified that I still have 3 users:

  • admin.
  • anonymous (but anonymous access are disabled.
  • a R+W user that is not admin.

These 3 users are “status = active” and their roles seem good: nx-admin for admin, nx-anonymous for anonymous.

When I try to log in as admin, if I enter a wrong password I have a message “incorrect username or password”. If I enter the right one, I have a basic welcome page.

I tried to access a link from my history: #admin/system/tasks
It asks me for my password again and again, and adds a log line each time I give the right pass:
INFO [qtp1211751945-47] admin - Created session for user: admin”.
But I can’t access the requested page.

I’m a bit stuck with my investigations here…
I run my Nexus instance in a docker container. It was running OSS-3.17, and I restarted it with OSS-3.19 during my investigations.
Apart from this web interface issue, it seems to work well: I can push & pull docker images as well as maven artifacts, with authentication.

If you’re using a reverse proxy make sure it is configured correctly:

Also as a test try using a private browsing window to bypass your browser’s cache and installed plugins.

1 Like

I tried tunneling the Nexus port to my machine, and it works.
So you found my problem at first try! Well done @rseddon, thanks a lot!

The reverse proxy had had a config change, forcing httponly secure cookies. The change had been applied globally, and of course some apps may not be happy with it. Fixed!