Proxy Error when downloading package from group repository

I have a group repo called “chocolatey-all” which contains 2 members a hosted repository called “chocolatey-hosted” and a proxy repo called “chocolatey-proxy” which is a proxy for

When I attempt to download the latest vmware-tools package from the chocolatey-all group repository using the following url$filter=(tolower(Id)%20eq%20'vmware-tools')%20and%20IsLatestVersion&semVerLevel=2.0.0

I get the error below 90% of the time and the cpu on the server I’m hosting nexus on spikes

Proxy Error

The proxy server received an invalid response from an upstream server.
The proxy server could not handle the request GET /repository/chocolatey-all/Packages().

Reason: Error reading from remote server

However when I run the same command against the proxy repository it works as expected.$filter=(tolower(Id)%20eq%20'vmware-tools')%20and%20IsLatestVersion&semVerLevel=2.0.0

I’ve tried invalidating the cache on the group repo with no luck.

Version: nexus OSS 3.64.0-04

Hi Nick, I think it would make sense to report this in Issues · sonatype/nexus-public · GitHub

Hey Matthew, thanks for the advice, will do

I put this on the Github issue as well, but posting here just to cover all bases:

I can’t reproduce your error, but as a very stupid suggestion, could you drop the trailing / off of and try your test again please? I’m wondering if it’s cloudflare doing weird things with the traffic because of the trailing slash.

Hi Stephen thanks for your response! Unfortunately removing the trailing slash on did not work

It was a long shot that I didn’t really expect to work. Is your proxy repro for sure setup to target Nuget v2? By default it’s Nuget v3. I’d expect a different error than what you’re seeing though if that were the case. This is bizarre!