Run on Java 11

Hello,

Is there any way to get Nexus repository working with JDK11; it is very difficult to install JDK8 on Debian Buster.

Cheers,

Neil

1 Like

No, unfortunately OpenJDK 8 is the only version that’s currently supported, but we are working on making Nexus Repository work on newer JDKs. No ETA yet.

Thanks; it may help to link to instructions on how to install adpotjdk’s JDK8 as this is the easiest way to get Java 8 onto a Debian box.

any update plan?

will you migrate the version in java11 or directly in java 17?
do you have now a plan for the migration?

We haven’t yet made a determination. The big hump will be getting past Java 9, after that migration to newer versions should be much easier.

1 Like