Service Won't Stop

Hey Everyone,
I can’t get Nexus to stop after I set it up to run as a service.

service nexus start

Works fine.

service nexus status
service nexus stop

Do not work. Both just return the “nexus is not running”. Same thing happens if I run the nexus script from the bin directory. Below is the bash verbose output from when I ran the command.

+ exec su - nexus /opt/nexus-3.30.1-01/bin/nexus stop
Shutting down nexus
+ exec /usr/java/jdk1.8.0_121/bin/java -server -Dinstall4j.jvmDir=/usr/java/jdk1.8.0_121 -Dexe4j.moduleName=/opt/nexus-3.30.1-01/bin/nexus -classpath /opt/nexus-3.30.1-01/.install4j/i4jruntime.jar:/opt/nexus-3.30.1-01/lib/boot/nexus-main.jar:/opt/nexus-3.30.1-01/lib/boot/activation-1.1.1.jar:/opt/nexus-3.30.1-01/lib/boot/jakarta.xml.bind-api-2.3.3.jar:/opt/nexus-3.30.1-01/lib/boot/jaxb-runtime-2.3.3.jar:/opt/nexus-3.30.1-01/lib/boot/txw2-2.3.3.jar:/opt/nexus-3.30.1-01/lib/boot/istack-commons-runtime-3.0.10.jar:/opt/nexus-3.30.1-01/lib/boot/org.apache.karaf.main-4.2.9.jar:/opt/nexus-3.30.1-01/lib/boot/osgi.core-6.0.0.jar:/opt/nexus-3.30.1-01/lib/boot/org.apache.karaf.specs.activator-4.2.9.jar:/opt/nexus-3.30.1-01/lib/boot/org.apache.karaf.diagnostic.boot-4.2.9.jar:/opt/nexus-3.30.1-01/lib/boot/org.apache.karaf.jaas.boot-4.2.9.jar com.install4j.runtime.launcher.UnixLauncher stop
nexus is not running.

I’m running nexus-3.30.1-01 on RHEL Kernel 2.6.32-754.33.1.el6.x86_64.

Nothing happens in the nexus logs when I issue the stop command.

I have to kill the process to get it to stop.

Where else can I look for info/logs to see what the problem might be?

It might be a problem with the PID file:

Definitely. There’s just a plus sign in there. hmmmmmmm