[Solved] Upgrade 2.14.14 -> 3.18.1: maven2 repo shown as yum and cannot be upgraded


i’m trying to upgrade our Nexus OSS 2 to 3 and followed the guide, so i first upgraded the Nexus 2 to the latest version (2.14.14-01), than installed the latest Nexus OSS 3 (3.18.1) in parallel and finally enabled the upgrade capability on both installations. Got the access token from Nexus 2 and used that in Nexus 3.
Started the upgrade wizard on Nexus 3 and selected the Download method (those are two separate hosts so i have to do that).

All worked fine so far but now when Nexus 3 presents me the list of repositories to migrate, it detects our Maven Release and Snapshot repo as having yum format and wont let me select the repos because “Repository format/type not supported”.

We had the “Yum: Generate Metadata” and the “Yum: Configuration” capability enabled on those repos so i assume thats why it thinks it’s a yum repo. I disabled those capabilities on Nexus 2 now and also tried to delete the repodata folder and restarted the Nexus 2 and ran update index and repair metadata afterwards but it still wont let me migrate those repositories.

I actually do not care about the yum packages. I just want all my maven artifacts to me migrated to the new nexus. So how can i achieve that now?

Another side question while i’m at it: Any recommendations on how i could get my npm packages from an existing Nexus 3 installation into the new one. We are actually consolidating two Nexus OSS installations as part of this upgrade. We had a Nexus 2 for Maven and a Nexus 3 for Docker and NPM and it should all be in this new Nexus 3 now.

Thanks for any input!

Oh s*** sorry nvm. It worked after restarting Nexus 3. I guess i leave this topic here if someone runs into a similar issue. Apparently Nexus 3 will not fully refresh the repository info when restarting the upgrade wizard.

So disabling the yum capabilities (and possibly deleting the repodata) in Nexus 2 and afterwards restarting Nexus 3 (!) solves the problem.