Unable to reach metadata file, instead get HTTP 404 Nof Found Error

We found some artifacts which metadata is listed in web browser but is not possible to load them instead returns HTTP 404 Not Found error.

Searching out in the web a possible cause is that might be solved by rebuilt metadata however the problem persists after rebuilt metadata or repair blobl and metadata. Also tried to remove the folder that conains such metadata but despite service returns deletion success the folder remains with corrupted metadata. Also tried to update metadata with a new artifact deploy but the problem persists. Alaso tried to delete folder by removing all the artifacts are contained in.

The following error message is triggered on log service after trying to opencorrupted metadata:

2020-11-12 21:52:16,397+0000 ERROR [qtp1561957316-52660] admin org.sonatype.nexus.extdirect.internal.ExtDirectExceptionHandler - Failed to invoke action method: coreui_Component.readAsset, java-method: org.sonatype.nexus.coreui.ComponentComponent.readAsset

Repository type: maven-snapshot

Try running the rebuild browse task, the tree is a synthetic representation of the repository content.

Thank you so much. Your suggestion resolve my problem.