Upgrade Nexus 3.0.2 to 3.1.0


#1

Hi guys,

I try to upgrade our Nexus from 3.0.2 to 3.1.0 (or later).
I’ve done all the preparations described here (How to Upgrade Nexus Repository Manager 3.0.2 to 3.1.0 or Later – Sonatype Support).

The Update always fails with the failure:
“File ‘key_store_name_idx.sbt’ already exists”.
If i rename the file …/sonatype-work/nexus3/db/.
If I start the nexus again the following error occurs:
“[FelixStartLevel] *SYSTEM org.sonatype.nexus.upgrade.internal.UpgradeServiceImpl - Problem upgrading config from 1.0 to 1.1
com.orientechnologies.orient.core.exception.OSchemaException: Cluster with id 23 already belongs to class upgrade_model_versions”

Can anyone help me upgrading the application?

Thanks and Regards.

Marco


#2

Hi Marco,

This forum isn’t the right place to debug technical problems.

If you have a support contract with us you can use our support system at https://support.sonatype.com. Please note that the support system is for licensed customers only.

Otherwise, if you think this is a bug, you can try raising an issue at https://issues.sonatype.org in the “Dev - Nexus” issue.

Either way, provide a support zip file if you can get to the Nexus Repo UI. Or provide the complete nexus.log file otherwise.

Regards,

Rich