Upgrading nexus from 3.0.2-02


I am trying to upgrade our Nexus 3.0.2-02. I got Nexus 3.26.2-02 working but with no data from the old system.
We not using the pro version so unfortunately I cannot export all blobs from old and import into the new system.
At my last attempt I tried to just get the same version working on the new server with 3.0.2-02 but I get the following error :

2020-08-24 10:11:41,654+0200 WARN [FelixStartLevel] *SYSTEM org.sonatype.nexus.repository.docker.internal.DockerConnectorFacetImpl - Validation failed; 1 constraints violated:
Port is already in use, type: class org.sonatype.nexus.validation.ConstraintViolationFactory$HelperBean, property: attributes.docker.httpPort, value: org.sonatype.nexus.validation.ConstraintViolationFactory$HelperBea
2020-08-24 10:11:41,662+0200 ERROR [FelixStartLevel] *SYSTEM org.sonatype.nexus.repository.manager.RepositoryManagerImpl - Failed transition: NEW -> STARTED
javax.validation.ConstraintViolationException: null

I would really appreciate som help in getting this resolved.



The error message says that the port you are using for your docker connector is already in use. You need to ensure your docker connector port is free to use by Nexus Repository Manager. You can change the port in your Docker repository settings or find what service is using that port and change it to other.

1 Like

Unfortunately I cannot change the Docker repository settings as I cannot access these settings because of this problem. I cannot access the Admin section (wheel).
Is there some way I can access this on the command line ?
This worked fine in 3.0.2-02 without a problem. I stuck as much as I could with How to Upgrade Nexus Repository Manager 3.0.2 to 3.1.0 or Later – Sonatype Support
I don’t understand why it does not work now. Right now I cannot seem it upgrade it.
Is it possible to export all repos and blobs and inport to the newest version?
Would that be easier. This I already got working but without the data.

ok, weird.
Looking around I found a support page where said to open a private browser window.
I could then access admin area.
How to Upgrade Nexus Repository Manager 3.0.2 to 3.1.0 or Later – Sonatype Support indicates that I needed to modify
nexus properites and comment out nexus edition and features but this was what causing an issue.
seems now to be working
now to continue upgrading until I get to the latest version … :expressionless:

1 Like