Why I could not download PDF from Nexus repository - blocked by client?

I have a Jenkins build process, which uploads a PDF file to a Nexus Repository using a command which is run by Jenkins Powershell plugin:

wget "$env:SERVICECOPYTARGET$serviceName/$pdfToPublish" -Method PUT -Credential $cred -Verbose -InFile $pdfFileFullPath -ErrorAction Stop

When I click it on the Nexus repository to download the pdf, I always get an error message like in the image below:
enter image description here

I have tried it in Chrome incognito, Microsoft Edge browser, however I still get the same error message.

Updating Chrome to the latest version does not help.

Any idea how to fix it?
P/S: I use Sonatype Nexus Repository ManagerOSS 3.29.2-02

I can upload zipped file to Nexus & download it successfully, but not for PDF file.

The text of your error message literally says an extension blocked it.

@mpiggott ,

I have removed all extensions at Chrome. It does not work.
I also have tested at Chrome Incognito, which has no extension at all.

And I tried using another browser - Microsoft Edge. It does not have any extension.

Yet, I still get the error message above.

Any advise/suggestion please?

Maybe try clearing your caches, both Chrome and Edge are using the chrome engine so they might be sharing a cache.

Hi @mmartz ,

I just cleaned my cache in Chrome. No luck :pensive:

I tested with old school Internet Explorer browser & it works :thinking:

I do not know what difference could there be between Internet Explorer & Chrome.

I’ve the same problem.
if I put the pdf in old nexus v2.x it work
in nexus v3.28 ERR_BLOCKED_BY_CLIENT

  1. Request URL: https…olympe-profiles-1.0.0-SNAPSHOT.pdf
  2. Request Method: GET
  3. Status Code: 304 Not Modified
  4. Remote Address:
  5. Referrer Policy: strict-origin-when-cross-origin
  6. Response HeadersView source
  7. Access-Control-Allow-Credentials: true
  8. Access-Control-Allow-Headers: DNT,X-CustomHeader,Keep-Alive,User-Agent,X-Requested-With,If-Modified-Since,Cache-Control,Content-Type,Authorization
  9. Access-Control-Allow-Methods: GET, PUT, POST, DELETE, PATCH, OPTIONS
  10. Access-Control-Allow-Origin: 2.
  11. Content-Disposition: inline
  12. Content-Length: 57164
  13. Content-Security-Policy: sandbox allow-forms allow-modals allow-popups allow-presentation allow-scripts allow-top-navigation
  14. Content-Type: application/pdf
  15. Date: Tue, 25 May 2021 12:08:21 GMT
  16. Last-Modified: Tue, 25 May 2021 11:59:01 GMT
  17. Server: nginx/1.15.10
  18. Strict-Transport-Security: max-age=15724800; includeSubDomains
  19. X-Content-Type-Options: nosniff
  20. X-XSS-Protection: 1; mode=block
  21. Request HeadersView source
  22. Accept: text/html,application/xhtml+xml,application/xml;q=0.9,image/avif,image/webp,image/apng,/;q=0.8,application/signed-exchange;v=b3;q=0.9
  23. Accept-Encoding: gzip, deflate, br
  24. Accept-Language: en-US,en;q=0.9
  25. Cache-Control: max-age=0
  26. Connection: keep-alive
  27. Cookie: _ga=GA1.2.1100789169.1613473185; sfbShellAppLaunched=yes; clientchoice=DesktopClient; NX-ANTI-CSRF-TOKEN=0.056010135917583304; _gid=GA1.2.145180223.1621943813
  28. DNT: 1
  29. Host: https…
  30. If-Modified-Since: Tue, 25 May 2021 11:59:01 GMT
  31. Referer: nexus-qualif.domain.fr/
  32. Sec-Fetch-Dest: document
  33. Sec-Fetch-Mode: navigate
  34. Sec-Fetch-Site: cross-site
  35. Sec-Fetch-User: ?1
  36. Sec-GPC: 1
  37. Upgrade-Insecure-Requests: 1
  38. User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.212 Safari/537.36

Canot post the all items this tool refuse 2 link in post
the url and referer are on same server

The error message you get:


says it was blocked by your browser. This usually turns out to be some browser extension. You can read about it here: How to Solve ERR_BLOCKED_BY_CLIENT - KeyCDN Support