Yum Package Groups Not Updating!

Hi all,

I’m using Nexus OSS 3.30.0-01 and am trying to get a Package Group to work. Following the instructions here doesn’t yield any results: Yum Repositories

The example has you upload comps.xml to the repodata directory which seems wrong to me, but I tried that as well. I’ve tried uploading a gzipped version of my comps.xml into the main directory and no luck there as well. The xml file generates an appropriate group when I use the “createrepo” command, but it doesn’t do anything when I upload the file to Nexus. I’ve tried uploading the comps.xml and THEN uploading another rpm to trick it into generating repodata, but that didn’t work either. I’ve used the task to regenerate the repodata and that didn’t work.

What am I doing wrong?


Our tests for this do also upload the file to repomd/comps.xml[.gz] you might need to change it slightly if you use a non-zero repo depth to include additional path segments. There is also a delay for yum repositories before metadata is rebuilt (iirc 60-seconds).

In some earlier versions of Nexus (sorry don’t have the version on hand) we had a bug that wouldn’t process the comps file unless an rpm was also added. If you aren’t already try with the latest versoin.