could not be fetched from the IQ Server

help

#1

Hi,

I’m trying to push a JS app to be scanned by IQ Server, but I’m getting could not be fetched from the IQ Server/failed to respond. I could send Go/Python/Java apps, but not JS app. I don’t know if it’s related to the app/language or the size of this project (~750MB).

[INFO] Fingerprinting completed in 265 seconds for 53 archives, 40797 total files
[INFO] Submitting scan to the IQ Server...
[INFO] Assigned scan ID <SCAN_ID>
[INFO] Fetching results of policy evaluation (ETA 15s)...
[ERROR] The policy evaluation results for scan ID <SCAN_ID> could not be fetched from the IQ Server
org.apache.http.NoHttpResponseException: my_iq_server:443 failed to respond
	at org.apache.http.impl.conn.DefaultHttpResponseParser.parseHead(SourceFile:141)
	at org.apache.http.impl.conn.DefaultHttpResponseParser.parseHead(SourceFile:56)
	at org.apache.http.impl.io.AbstractMessageParser.parse(SourceFile:259)
	at org.apache.http.impl.DefaultBHttpClientConnection.receiveResponseHeader(SourceFile:163)
	at org.apache.http.impl.conn.CPoolProxy.receiveResponseHeader(SourceFile:157)
	at org.apache.http.protocol.HttpRequestExecutor.doReceiveResponse(SourceFile:273)
	at zz.p.a(SourceFile:29)
	at zz.p$a.a(SourceFile:111)
	at zz.p.execute(SourceFile:53)
	at org.apache.http.impl.execchain.MainClientExec.execute(SourceFile:272)
	at org.apache.http.impl.execchain.ProtocolExec.execute(SourceFile:185)
	at org.apache.http.impl.execchain.RetryExec.execute(SourceFile:89)
	at org.apache.http.impl.execchain.RedirectExec.execute(SourceFile:110)
	at org.apache.http.impl.client.InternalHttpClient.doExecute(SourceFile:185)
	at org.apache.http.impl.client.CloseableHttpClient.execute(SourceFile:72)
	at zz.m$a.a(SourceFile:157)
	at zz.m$a.a(SourceFile:103)
	at zz.e.a(SourceFile:37)
	at zz.h$c.a(SourceFile:107)
	at com.sonatype.insight.scan.cli.c.a(SourceFile:180)
	at com.sonatype.insight.scan.cli.c.a(SourceFile:60)
	at com.sonatype.insight.scan.cli.j.a(SourceFile:89)
	at com.sonatype.insight.scan.cli.d.run(SourceFile:27)
	at com.sonatype.insight.scan.cli.PolicyEvaluatorCli.main(SourceFile:17)
Command exited with non-zero status 1
real	5m 46.51s
user	0m 28.03s
sys	0m 29.68s

I tried to send via Jenkins plugin and IQ CLI. I got the same error in both cases.
Nexus Platform Plugin -> 3.5.20190425-152158.c63841b
IQ CLI -> nexus-iq-cli-1.64.0-02.jar

Regards,

Matheus Lozano


#2

This looks like something that would be better handled via a support ticket. I suggest raising one at https://support.sonatype.com


#3

Hi @rseddon,

Thanks for your reply. I created the ticket via support, but I can’t access it anymore. I’m getting “Error: An internal error occurred.”, when I try to login via Login to Sonatype

Has another way to login or check the ticket? This is the ticket that I got via e-mail: http://support.sonatype.com/hc/requests/34717

Regards,

Matheus Lozano