Npm "No matching version found"

Once again, I am getting an error when I attempt install an npm package with NXRM npm-group that is configured as registry in the npmrc: npm ERR! code ETARGET

In this case the package is json5, which was published 16 days ago and which installs fine when I do NOT set my registry to NXRM.

Is there a general solution for this? “Just wait is out” is unacceptable.

Hi Thad,
Sorry for this inconvenience. Please file a ticket in our tracker with reproduction steps and/or attach your support.zip created right after you have reproduced the issue on your instance.

Done: NEXUS-31752

When I say, “Once again,” I am referring to Cannot install with registry npm-group
This is a recurring problem, and not just for myself.

This appears like it might have been a corrupted local npm cache. I ran npm install on another machine, the troublesome package installed, and the new version was in my npm-group registry.

I went back to the first machine. It still failed until I ran npm cache clean --force. Now it works.

1 Like