Npm oudated

Hi,
Should npm outdated trigger the nexus npm repository to check, for latest variants, or just get the ones already there ?
I am having issues, with this, can not run npm oudated, because it only shows the versions already inside the repo. Maybe a cache issue ?