Source Control Evaluation REST API

I’ve made a scripting to automate my process of import application from GitLab to Lifecycle using API.
Tha whole process has worked , I’ve configured via API the applications with their SCM, but when I’ve used API “Source Control Evaluation REST API”, I’ve received an error that I didn’t have a report with data. By the way, I took the same application and I evaluated by a binary, and configurated the SCM in Organizations. And both, I got a report data, but when I’ve configurated the SCM in application or via API, I didn’t had data report.
Had someone has a similar issues?

Hi @douglas.silva & welcome!

I wanted to make sure you knew there was documentation for the Source Control Evaluation REST API. I’m not sure if it will answer your question but it might be a good place to start - you can find it here: Source Control Evaluation REST API - v2

Thank you @mharwood !

I resolved, actually I’ve mistaken the Body when create a SCM in POST API, I was passing a parameter that doesn’t exist, and the other error occured

I’ve just passed the simples parameters and these worked.

Glad it was resolved, @douglas.silva!